Помощь начинающим *nix-пользователям

Qvazi

Ословед
Снова я. Ubuntu 10.10.
В браузере не отображается видео (Youtube и ему подобные). На месте видео серое окошечко и все. Браузер mazilla и флеш стоит.
 

Namenloss

Сотрудник ИС
Снова я. Ubuntu 10.10.
В браузере не отображается видео (Youtube и ему подобные). На месте видео серое окошечко и все. Браузер mazilla и флеш стоит.
Ну так наверно надо посмотреть, видит ли firefox установленные плагины. В строке адреса about:plugins и там посмотреть, если нет загуглить как ставить и поставить.
 

Difur

Ословед
Восстановление в MBR загрузчика grub

Начальные условия: Linux (c разделом для /boot), производится установка Windows.
Граничные условия: Имеется live cd.
Задача: Установить Grub в mbr.
Ответ будет полезен, особенно на заметку новичкам...

Решение поставленной задачи:
1. Загружаемся с live cd.
2. Подготовка и вход в
окружение Change Root.
2.1 Получение информации о разделах жесткого диска
Код:
# fdisk -l

Диск /dev/sda: 160.0 ГБ, 160041885696 байт
255 heads, 63 sectors/track, 19457 cylinders, всего 312581808 секторов
Units = секторы of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x21d644b8

Устр-во    Загр     Начало       Конец       Блоки   Id  Система
/dev/sda1   *          63      192779       96358+   7  HPFS/NTFS
/dev/sda2          192780    80196479    40001850    7  HPFS/NTFS
/dev/sda3   *    80196480    80389259       96390   83  Linux
/dev/sda4        80389260   312576704   116093722+   5  Расширенный
/dev/sda5        80389323   100390184    10000431   83  Linux
/dev/sda6       100390248   104390369     2000061   82  Linux своп / Solaris
/dev/sda7       104390433   208475504    52042536   83  Linux
/dev/sda8       208475568   312576704    52050568+   7  HPFS/NTFS
Таким образом видно: '/' находится в разделе sda5, а '/boot' - sda3 (последнее чуть позже проверим)

2.2 Подготовка и вход в Change Root

Код:
# mkdir /mnt/nix
# mount /dev/sda5 /mnt/nix
# cd /mnt/nix
# mount -t proc proc proc/
# mount -t sysfs sys sys/
# mount -o bind /dev dev/
# mount /dev/sda3 boot/
# chroot . /bin/bash
3. Установка grub
Код:
# grub
GNU GRUB  version 0.97  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename. ]

grub> find /grub/stage1
 (hd0,2)

grub> root (hd0,2)
 Filesystem type is ext2fs, partition type 0x83

grub> setup (hd0)
 Checking if "/boot/grub/stage1" exists... no
 Checking if "/grub/stage1" exists... yes
 Checking if "/grub/stage2" exists... yes
 Checking if "/grub/e2fs_stage1_5" exists... yes
 Running "embed /grub/e2fs_stage1_5 (hd0)"...  25 sectors are embedded. succeeded
 Running "install /grub/stage1 (hd0) (hd0)1+25 p (hd0,2)/grub/stage2 /grub/menu.lst"... succeeded
Done.

grub>
Замечания:
1. Пользователь gensmx - "все приведённые выше команды должны выполняться с правами пользователя root или от обычного - через sudo, обосновывая это тем, что не все live cd имеют возможность непосредственной сессии с правами root".
2. Пользователь fooser - "и между прочим windows в мбр свой загрузчик не ставит, она наоборот стирает оттуда неизвестный неопознаный мусор (граб), и потом при первом же ребуте биос видя пустой мбр записывает туда свой загрузчик".
 
Добрый вечер.Прошу помощи.Проблема с ubuntu 10.04
Перестал запускаться графический интерфейс. Загружается система,и на экране застывает что-то непонятное(2 куска изображения загрузки убунты, 2 зеленые полосы,ну наверное это не играет роли) Чтение лога Xlog.0.log дало понять, что виноваты установленные по-глупости драйвера Radeon.
В связи с этим вопрос:Возможно ли откатить все графические настройки, драйвера до состояния, в котором они были при первом запуске системы?Если нет, что я могу сделать еще? Как я понял понятие "точка востановления" тут отсутствует? (
Знание командной строки *nix на минимуме, изучу по ходу, буду рад ссылке на статью,способную мне помочь, или примерному алгоритму.
 

Rustam008

Ословед
[LINE]Стоит ubuntu 10.4; в Центре приложений Ubuntu при установке wine - скачивается, устанавливается, потом доходит до 86%-применение изменений и все!!-стоит как вкопанный не могу др. приложения поставить из-за очереди, что делать?? до этого другие приложения ставились с лету. Даже ОС переустанавливал одно и тоже.
Да, кстати, вайн в приложениях появляется и более того работает!! но из установки не вылезает.[/LINE] - так ладно - оказывается нужно было всего лишь подождать 2 часа - делов то :)

А почему при запуске диска в приводе он нигде и никак не отображается, даже звука запуска не слышно. (с флешками все норм)
 
Уж сорри за оффтоп: разобрался по мелочи в убунте, вещь! Даже не знал, что винда, оказывается, такое г..но %)
Все очень удобно и не требует обслуживания. Только руки выпрямляй и радуйся. Доволен. Линуксу +1 и +100500 тем ребятам, которые меня агитировали пересесть с винды :)
 

    OpenSource

    очки: 6
    Поздравляю с открытием правильного мира! :)

Snowy White

Ословед
Уж сорри за оффтоп: разобрался по мелочи в убунте, вещь! Даже не знал, что винда, оказывается, такое г..но %)
Все очень удобно и не требует обслуживания. Только руки выпрямляй и радуйся. Доволен. Линуксу +1 и +100500 тем ребятам, которые меня агитировали пересесть с винды :)

Зато у мелкомягких есть пиченьки =D
 

    Outwave

    очки: 21
    Нет комментариев
Доброй ночи!
Установил EduUbuntu и не получатся установить анлим-инет.
На страницу is74 захожу, локалка работат, а vpn выдает "произошел сбой VPN-соединения "vpn".
настраиваю через NetworkManager 0.8.1. по инструкции, присоветованной выше здесь на форуме http://mirror.ddns.is74.ru/html/vpn.htm
Помогите, плиз!
 
Люди добрые, помогите разобраться.
В компе 2 диска: wd 320 gb и SSD cricial 64 gb
Если монтировать /boot на SSD то ubuntu устанавливается корректно, просит извлечь диск,
перезагружается, проходит POST и все! то есть мигающая полоска. реагирует только на ctrl+alt+del
Поставил /boot на WD, остальные разделы на SSD - все работает.
В чем может быть причина?
 

MahMahoritos

Ословед
В BIOS надо прописать правильный порядок загрузки с дисков. Очевидно, система пытается грузиться с WD
 
В BIOS надо прописать правильный порядок загрузки с дисков. Очевидно, система пытается грузиться с WD
Забыл сказать, приоритеты дисков менял.
В принципе, месторасположение /boot'a для меня не критично, система загружается на несколько секунд дольше,
просто интересно почему так происходит? :idontno:
 

KapaM6a

Самец :)
Товарищи помогите пожалуйста, пишу PAM модуль, но дело в том что не могу найти .h файлы в /lib/security/
Что делать? какой пакет скачать для убунты? Или для арча?
И сразу вопрос, с федорой много проблем? а то поставил а щас парюсь. И да как на неё иксы поставить(какие именно пакеты)?
 

Meltdown

Ословед
Товарищи помогите пожалуйста, пишу PAM модуль, но дело в том что не могу найти .h файлы в /lib/security/
su -c 'yum install pam-devel'
И сразу вопрос, с федорой много проблем? а то поставил а щас парюсь. И да как на неё иксы поставить(какие именно пакеты)?
И сразу вопрос, как Вы ее ставили, что аж без иксов?
 

Namenloss

Сотрудник ИС
Товарищи помогите пожалуйста, пишу PAM модуль, но дело в том что не могу найти .h файлы в /lib/security/
Что делать? какой пакет скачать для убунты? Или для арча?
И сразу вопрос, с федорой много проблем? а то поставил а щас парюсь. И да как на неё иксы поставить(какие именно пакеты)?
А не рано ли PAM модуль писать с такими познаниями?
 

KapaM6a

Самец :)
su -c 'yum install pam-devel'

И сразу вопрос, как Вы ее ставили, что аж без иксов?

Ну я голую брал:)

А не рано ли PAM модуль писать с такими познаниями?

Нужно пробовать. Плюс код я уже написал, не хватает только пам библиотек:) хотя бы проверить, сработает или нет
 

HD Radio

HDR | LOUNGE & CHILL [AAC-LC 192 kbps]
  • Сверху