Эмуляторы: установка, настройка и эксплуатация

ck80

Ословед
Награды
4
А у кого-нибудь запустился ДубльГИС под вайном? У меня запускается его заставка и тут же ошибка "Не найден файл данных. Инсталлируйте систему заново"

Ubuntu 7.04. Wine-0.9.49 из пакета.

Тьфу блин. Вопрос снимается. Только что попробывал устанивть через вайн. Все заработало. :)
 

L_ninyo

Ословед
а для 64bit Мандривы 2008 есть?

Собери из сорцов под свою архитектуру раз не можешь бинарный пакет найти.


Ещё вот такая поправочка, например на Ubuntu 64 ставят пакет для 32 путём доставки дополнительных библиотек и ещё чего-то там. Подробнее в вопрос не вникал, но можешь почитать тут http://wiki.winehq.org/UbuntuAMD64 на ENG написанно. Wine под x64 похоже действительно собрать не удастся из сорцов.
 
Wine-0.9.52

This is release 0.9.52 of Wine, a free implementation of Windows on Unix.
- Улучшена поддержка графических планшетов.
- Поддержка RPC context handles.
- Исправлены проблемы с глубиной цвета.
- Реализована директория "Мое сетевое окружение".
- Множество багфиксов..
wine-0.9.52.tar.bz2 12.37 Мб 49.[236-239]

+Bonus
DEB пакет для Ubuntu7.10
wine_0.9.52_winehq0_ubuntu_7.10-1_i386.deb 9.50 Мб 49.[236-239]
 
This is release 0.9.54 of Wine, a free implementation of Windows on Unix.

What's new in this release:
- Photoshop CS/CS2 should now work, please help us testing it.
See http://wiki.winehq.org/AdobePhotoshop for details.
- A number of RPC fixes.
- Various improvements to the debugger support.
- Lots of bug fixes.
Д. Шурупов
В Wine 0.9.54 запускается Adobe Photoshop CS/CS2
Вышла новая версия свободной реализации Windows API — Wine 0.9.54.
Как сообщают разработчики Wine, главной новостью в представленном релизе 0.9.54 стала возможность запуска программы Photoshop CS/CS2 в GNU/Linux- и UNIX-подобных операционных системах. Но при этом они просят помочь им с тестированием.
Среди других изменений в Wine 0.9.54 — многочисленные исправления (в особенности, в RPC), улучшения в поддержке отладчика.



wine-0.9.54.tar.bz2 12.50 Мб 49.[236-239]
 

Yuri_K

Администрация
Награды
4
Скажите - возможно ли установить вайн для мандривы 2008 на мандриву 2007 года?
И если да то будет ли он работать?

Что-то у меня пока ни разу не получалось поставить пакет от 2008 на 2007 (правда я мало пытался). А чем вайн для 2008 лучше вайна для 2007?
 

L_ninyo

Ословед
Проще, собирайте пакеты из сорцов (свежие версии выкладываются регулярно, см.выше в теме). Самостоятельно собраный пакет из свежих исходников зачастую намного лучше того "Г" что валяется в репозитариях + можно собрать с какими нужно опциями соответственно убрав или добавив функционал...

Почитайте про checkinstall. Есть так же и другие способы сборки пакетов под ваш дистрибутив.
 

Yuri_K

Администрация
Награды
4
....Самостоятельно собраный пакет из свежих исходников зачастую намного лучше того "Г" что валяется в репозитариях....

Согласен. Только в случае с Wine на sourceforge официально выкладываются очень приличные пакеты для Mandriva 2006, 2007, 2007.1, 2008, поэтому и непонятно, зачем ставить от 2008 если есть под любую (актуальную) Мандриву.
 

L_ninyo

Ословед
Не мучайся, человек. Собери пакет сам - сорцы в сети (в ослосети видел 55 если не изменяет память) валяются , причём постоянно обновляемые. Чекинстал в пом. или подобное...
 
Wine 0.9.56

0.9.56 уже давно валяется :)
Что нового:
Должная обработка OpenGL/Direct3D окон с менюшками.
заглушки на все d3dx9_xx dll'ки.
Несколько графических оптимизаций.
Много исправлений установщика.
Улучшена поддержка MIME сообщений.
wine-0.9.56.tar.bz2 12.57 Мб
 
пытаюсь скомпиллировать вайн 56(все по инструкции).....пишет

root@DIAMOND:/home/boris/Рабочий стол/wine-0.9.56# ./configure
configure: error: cannot find sources (server/atom.c) in . or ..
root@DIAMOND:/home/boris/Рабочий стол/wine-0.9.56#
 
Сверху